Interface Hangs When Adding Components

Hi, I’m trying to assembly a simple project: An Arduino Mega with 7 rotary encoders. I can add 5 encoders, each addition take a little longer than the previous one. Once I try to add a 6th, the interface just hangs and never reconciles. If I swap the Mega for a Leonardo, I can add 6, but the 7th one hangs. Any advice?

I’m seeing the same here (I’ve highlighted the spinner with a light blue box):

I tried to create it via the URL (components are listed by ID) and that won’t work either.,11061,217614,217614,217614,217614,217614,217614,217614

But you don’t really need them all on the circuit for a project; you can just copy-paste the code that’s generated for an encoder and increment the number after downloading the project code.

Thanks! I have tried the Copy/Paste method to add the last encoders. They are recognized. I think because the last ones added need to use the analog pins as digital. Is there code that’s needs to be added so that the analog pins are recognized as digital?

Sorry, that’s beyond my knowledge level. I think you can just treat them like normal digital pins by setting them high or low. I’d like to know if you find out.